Physics Simulation Forum

 

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Building just the libs
PostPosted: Thu Feb 07, 2013 8:56 am 
Offline

Joined: Sat Apr 28, 2012 10:11 am
Posts: 6
Hi all,

I have zero knowledge of cmake, and I'm having serious trouble finding out which options to set and which options to leave alone. (I'm using a cmake gui tool so at least I see what options are there, phew.)

Here's my use case:
1) Needs to use doubles.
2) Just compile the libs. Don't install them anywhere.
3) Not sure how to get debug symbols. Is there a large performance difference between builds with and without debug info?
4) I'll want to wrap the lib in Java later on. Probably not of any direct relevance to the question, I'm mentioning this to better define the use case.

I have looked in the docs but came up empty.
In case I overlooked it, a pointer would do nicely, otherwise, I'll need a short run-down of what options to set.

Thanks in advance.


Top
 Profile  
 
PostPosted: Thu Feb 07, 2013 11:43 pm 
Offline

Joined: Mon Feb 04, 2013 12:12 pm
Posts: 9
If you use vs2005, 2008 or 2010 just navigate to BulletDir\build\YOURVERSION, start up the solution and hit build.

The libs end up in BulletDir\lib which you need to include in your own project.


Top
 Profile  
 
PostPosted: Fri Feb 08, 2013 4:49 am 
Offline
User avatar

Joined: Fri Jan 25, 2013 1:51 pm
Posts: 10
I just generated a solution for very similar build requirements. Here's a pretty thorough story of what I did:

1. Open CMakegui, and point to the source code and binary build directories. The source dir is the local svn repo, and the build is just some new folder the projects/solution will be dumped to.
2. Make sure you have the "Grouped" and "Advanced" checkboxes checked.
3. In the "Use" group, make sure USE_DOUBLE_PRECISION is checked off.
4. Check off other stuff/provide paths for options you want. Just make sure to look through each group to make sure you don't miss anything.
5. Click configure to run a few iterations, watching for red sections @ the bottom panel. Try to correct what you can if you missed a checkbox/path.
6. Click "Generate," and projects/solution file will be dumped to the directory specified in step 1.

Notes:
In the generated project, the default "Rebuild Solution" will simply build the libs to the output dir, but won't install them to the install dir. There's a separate project you can build for installing the libs.
I'm pretty sure the default Debug and ReleaseWithDebInfo build configurations will dump the symbols along with the libs. Not sure about the performance differences, though, sorry.

Good luck. I hope this helps at least someone!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: Bing [Bot], fractalord, Google [Bot], Yahoo [Bot] and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group